libtasn1: don't build host shared libs 16949/head
authorRosen Penev <rosenp@gmail.com>
Mon, 18 Oct 2021 08:19:20 +0000 (01:19 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 21 Oct 2021 21:45:32 +0000 (14:45 -0700)
Avoids rpath hacks.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libtasn1/Makefile

index e5bf554fe7ef22dbcdc5aef451a2e530fb419099..264a13a1d9e27ea34b1741e48e8b9df5095f71cb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtasn1
 PKG_VERSION:=4.16.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -43,6 +43,10 @@ HOST_CFLAGS += -std=gnu99
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
+HOST_CONFIGURE_ARGS += \
+       --disable-shared \
+       --with-pic
+
 CONFIGURE_ARGS += \
        --disable-doc \
        --disable-gcc-warnings \