getdns: Package update to replace libidn support with libidn2 5929/head
authorDavid Mora <iamperson347+public@gmail.com>
Tue, 17 Apr 2018 22:10:59 +0000 (18:10 -0400)
committerDavid Mora <iamperson347+public@gmail.com>
Tue, 17 Apr 2018 22:10:59 +0000 (18:10 -0400)
Package update to replace libidn support with libidn2

Signed-off-by: David Mora <iamperson347+public@gmail.com>
libs/getdns/Config.in
libs/getdns/Makefile

index c1246a3cae937d93d18b4f7d7ad575fa35d6a4ef..f6658d4e171a1c096d8a8f61438851f03f86b010 100644 (file)
@@ -7,10 +7,10 @@ config GETDNS_ENABLE_STUB_ONLY
                getdns can be configured for stub resolution mode only. (Removes libunbound dependency)
        default y
        
-config GETDNS_ENABLE_IDN_LIBIDN
-       bool "GETDNS_ENABLE_IDN_LIBIDN"
+config GETDNS_ENABLE_IDN_LIBIDN2
+       bool "GETDNS_ENABLE_IDN_LIBIDN2"
        help 
-               getdns can be configured with some IDN Support. (Requires libidn dependency)
+               getdns can be configured with some IDN Support. (Requires libidn2 dependency)
        default n
 
 endmenu
index 74027fd25d82bdcee9b7894257d711a0f6f90239..b9245fbe959cbb3cf9faf183a1841e464fb83db5 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=getdns
 PKG_VERSION:=1.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -22,7 +22,7 @@ PKG_INSTALL:=1
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_GETDNS_ENABLE_STUB_ONLY \
-       CONFIG_GETDNS_ENABLE_IDN_LIBIDN 
+       CONFIG_GETDNS_ENABLE_IDN_LIBIDN2 
        
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,7 +36,7 @@ define Package/getdns
        SECTION:=libs
        CATEGORY:=Libraries
        TITLE+= (library)
-       DEPENDS+= +libopenssl +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN:libidn
+       DEPENDS+= +libopenssl +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN2:libidn2
        MENU:=1
 endef
 
@@ -51,8 +51,8 @@ endef
 
 CONFIGURE_ARGS += \
                $(if $(CONFIG_GETDNS_ENABLE_STUB_ONLY), --enable-stub-only, ) \
-               $(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN), , --without-libidn ) \
-               --without-libidn2 \
+               --without-libidn \
+               $(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2), , --without-libidn2 ) \
                --with-ssl="$(STAGING_DIR)/usr" \
 
 define Build/InstallDev