lua-rs232: remove build timestamp 5218/head
authorAlexander Couzens <lynxis@fe80.eu>
Sun, 3 Dec 2017 12:06:56 +0000 (13:06 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 3 Dec 2017 13:26:45 +0000 (14:26 +0100)
Build timestamp prevents reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
lang/lua-rs232/Makefile
lang/lua-rs232/patches/100-remove-build-timestamps.patch [new file with mode: 0644]

index cf4ad7e7ef691c167e9342ad6164415e2a922012..492d8cc83f2e66a216df5113f694bb0d0f8d3ce4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua-rs232
 PKG_VERSION:=1.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
 PKG_LICENSE:=MIT
 
diff --git a/lang/lua-rs232/patches/100-remove-build-timestamps.patch b/lang/lua-rs232/patches/100-remove-build-timestamps.patch
new file mode 100644 (file)
index 0000000..fe59e2c
--- /dev/null
@@ -0,0 +1,22 @@
+Index: lua-rs232-1.0.3/bindings/lua/luars232.c
+===================================================================
+--- lua-rs232-1.0.3.orig/bindings/lua/luars232.c       2014-06-05 09:48:23.000000000 +0200
++++ lua-rs232-1.0.3/bindings/lua/luars232.c    2017-12-03 13:03:51.008917783 +0100
+@@ -31,7 +31,6 @@
+ #include "librs232/rs232.h"
+-#define MODULE_TIMESTAMP __DATE__ " " __TIME__
+ #define MODULE_NAMESPACE "luars232"
+ #define MODULE_VERSION "1.0.3"
+ #define MODULE_BUILD "$Id: luars232.c 15 2011-02-23 09:02:20Z sp $"
+@@ -483,9 +482,6 @@
+       lua_pushstring(L, MODULE_BUILD);
+       lua_setfield(L, -2, "_BUILD");
+-      lua_pushstring(L, MODULE_TIMESTAMP);
+-      lua_setfield(L, -2, "_TIMESTAMP");
+-
+       lua_pushstring(L, MODULE_COPYRIGHT);
+       lua_setfield(L, -2, "_COPYRIGHT");