boost: Version Update -> 1.66.0 5331/head
authorCarlos Miguel Ferreira <carlosmf.pt@gmail.com>
Thu, 28 Dec 2017 13:29:43 +0000 (13:29 +0000)
committerCarlos Miguel Ferreira <carlosmf.pt@gmail.com>
Thu, 28 Dec 2017 13:29:43 +0000 (13:29 +0000)
This package release updates boost to version 1.66.0.
Boost 1.66.0 brings three new header-only libs:
- Beast [1]: Portable HTTP, WebSocket, and network operations using only C++11
             and Boost.Asio, from Vinnie Falco.
- CallableTraits [2]: A spiritual successor to Boost.FunctionTypes,
                      Boost.CallableTraits is a header-only C++11 library for
                      the compile-time inspection and manipulation of all
                      'callable' types. Additional support for C++17 features,
                       from Barrett Adair.
- Mp11 [3]: A C++11 metaprogramming library, from Peter Dimov.

More info about this release, can be found in [4].

[1]: http://www.boost.org/doc/libs/1_66_0/libs/beast/doc/html/index.html
[2]: http://www.boost.org/doc/libs/1_66_0/libs/callable_traits/doc/html/index.html
[3]: http://www.boost.org/doc/libs/1_66_0/libs/mp11/doc/html/mp11.html
[4]: http://www.boost.org/users/history/version_1_66_0.html

Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
libs/boost/Makefile
libs/boost/patches/010-fiber_fix_0506e46640989e1f919388ad36890bd6063cd43a.patch [deleted file]

index 351d36a373f5cc0272c8648790eee32c6f105674..d9040922d592004c511dbfbab38f8c89c8114787 100644 (file)
@@ -16,15 +16,15 @@ include $(INCLUDE_DIR)/nls.mk
 include $(INCLUDE_DIR)/target.mk 
 
 PKG_NAME:=boost
-PKG_VERSION:=1.65.1
-PKG_SOURCE_VERSION:=1_65_1
-PKG_RELEASE:=2
+PKG_VERSION:=1.66.0
+PKG_SOURCE_VERSION:=1_66_0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://sourceforge.net/projects/boost/files/boost/$(PKG_VERSION)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
-PKG_HASH:=9807a5d16566c57fd74fb522764e0b134a8bbe6b6e8967b83afefd30dcd3be81
+PKG_HASH:=5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9
 PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
 PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
 
@@ -44,7 +44,7 @@ define Package/boost/Default
 endef
 
 define Package/boost/description
-This package provides the Boost v1.65.1 libraries.
+This package provides the Boost v1.66.0 libraries.
 Boost is a set of free, peer-reviewed, portable C++ source libraries.
 
 -----------------------------------------------------------------------------
@@ -82,7 +82,7 @@ This package provides the following run-time libraries:
  - regex
  - serialization and wserialization
  - signals
- - stackstrace (new in 1.65.0)
+ - stackstrace
  - system
  - thread
  - timer
@@ -90,7 +90,7 @@ This package provides the following run-time libraries:
  - wave
 
 There are many more header-only libraries supported by Boost.
-See more at http://www.boost.org/doc/libs/1_65_1/
+See more at http://www.boost.org/doc/libs/1_66_0/
 endef
 
 PKG_BUILD_DEPENDS:=boost/host PACKAGE_python:python PACKAGE_python3:python3
diff --git a/libs/boost/patches/010-fiber_fix_0506e46640989e1f919388ad36890bd6063cd43a.patch b/libs/boost/patches/010-fiber_fix_0506e46640989e1f919388ad36890bd6063cd43a.patch
deleted file mode 100644 (file)
index bcb2bad..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: boost_1_65_1/libs/fiber/src/numa/linux/pin_thread.cpp
-===================================================================
---- boost_1_65_1.orig/libs/fiber/src/numa/linux/pin_thread.cpp
-+++ boost_1_65_1/libs/fiber/src/numa/linux/pin_thread.cpp
-@@ -9,6 +9,7 @@
- extern "C" {
- #include <pthread.h>
- #include <sched.h>
-+#include <string.h>
- }
- #include <system_error>