openssh-server: manually set path to passwd binary
authorRucke Teg <rucketeg@protonmail.com>
Thu, 10 Feb 2022 22:04:43 +0000 (23:04 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 11 Feb 2022 05:10:08 +0000 (21:10 -0800)
In the build environment the autotools finds the `passwd` binary in
/usr/bin. But in the target image it is available under /bin instead.
Manually set the path to `passwd` binary to `/bin/passwd`

Signed-off-by: Rucke Teg <rucketeg@protonmail.com>
net/openssh/Makefile

index d384a20524613463186fcff971f3dd7284b82b45..6ba72bf7028f9076a3911e4ed61987811d60b58a 100644 (file)
@@ -183,7 +183,7 @@ CONFIGURE_ARGS += \
        --without-pam
 endif
 
-CONFIGURE_VARS += LD="$(TARGET_CC)"
+CONFIGURE_VARS += LD="$(TARGET_CC)" PATH_PASSWD_PROG="/bin/passwd"
 
 ifeq ($(BUILD_VARIANT),with-pam)
 TARGET_LDFLAGS += -lpthread