bmx7: update source (fixing several DoS scenarios)
[feed/routing.git] / bird / Makefile
index 5f8200c8a94fdbfca81e9bd1fadbc73cf9faef57..be624605b6be0ce855c45785d50242d77abf68cb 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2009-2015 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,13 +7,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird
-PKG_VERSION:=1.4.5
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
-PKG_MD5SUM:=a8e5e0a9129ce30fe6102c593bafb763
+PKG_MD5SUM:=4c92ec3548a2a120243879b6ef7046dd
 PKG_BUILD_DEPENDS:=libncurses libreadline
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
@@ -161,6 +163,8 @@ endef
 
 CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)"
 
+TARGET_CFLAGS+=-std=gnu89
+
 define Build/Template
 
 $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)