cjdns: update to 21
authorRosen Penev <rosenp@gmail.com>
Fri, 11 Dec 2020 03:07:44 +0000 (19:07 -0800)
committerMoritz Warning <moritzwarning@web.de>
Sat, 26 Dec 2020 11:52:20 +0000 (11:52 +0000)
Fixed compilation with musl 1.2.x , mostly.

Added a patch fixing compilation on 32-bit platforms.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
cjdns/Makefile
cjdns/patches/001-five-mins-builder-zonk.patch
cjdns/patches/010-musl-12x.patch [new file with mode: 0644]

index e9def01f76d6b3ef40bdea37e94ac74079f88953..ae5fdb34d72f18b8d51e2ab83c1c62c27bfef2bb 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cjdns
-PKG_VERSION:=v20.4
-PKG_RELEASE:=3
+PKG_VERSION:=v21
+PKG_RELEASE:=1
 
 PKG_SOURCE_VERSION:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/cjdelisle/cjdns.git
-PKG_MIRROR_HASH:=5e0036660626c3acf0050cf2e47aa87d262474184efb9d69538dbab4512113f8
+PKG_MIRROR_HASH:=ee22f5a94b56ac75ff8e3bc7bfaa70c45985c3dcf2a260c03e7754f4102da46a
 
 PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
 PKG_LICENSE:=GPL-3.0-or-later
index afd2d456fa94367338aba6e32aa028e8ddfd58ae..3128fb8bd2429b5a35b764c7d7d349699c644ac0 100644 (file)
@@ -1,13 +1,13 @@
 --- a/node_build/builder.js
 +++ b/node_build/builder.js
-@@ -203,8 +203,8 @@
-     // # 74 "./wire/Message.h"
-     js = js.replace(/\n#.*\n/g, '');
+@@ -215,8 +215,8 @@ var execJs = function (js, builder, file
+     js = qs.join("'");
      var to = setTimeout(function () {
 -        throw new Error("Inline JS did not return after 120 seconds [" + js + "]");
 -    }, 120000);
 +        throw new Error("Inline JS did not return after 5 minutes [" + js + "]");
 +    }, 300000);
-
      var REQUIRE = function (str) {
          if (typeof(str) !== 'string') {
diff --git a/cjdns/patches/010-musl-12x.patch b/cjdns/patches/010-musl-12x.patch
new file mode 100644 (file)
index 0000000..d82a144
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/memory/Allocator.c
++++ b/memory/Allocator.c
+@@ -57,7 +57,7 @@ static void unroll(struct Allocator_pvt*
+     struct Allocator_Allocation_pvt* allocation = context->allocations;
+     while (allocation && includeAllocations) {
+         writeUnroller(&childUnroller);
+-        fprintf(stderr, "%s:%ld [%lu] bytes at [0x%lx]\n",
++        fprintf(stderr, "%s:%tu [%tu] bytes at [0x%lx]\n",
+                 allocation->fileName,
+                 allocation->lineNum,
+                 allocation->pub.size,