batman-adv: Add openwrt revision to internal version
authorSven Eckelmann <sven@narfation.org>
Sun, 7 Oct 2018 09:10:05 +0000 (11:10 +0200)
committerSven Eckelmann <sven@narfation.org>
Sun, 14 Oct 2018 14:04:31 +0000 (16:04 +0200)
OpenWrt is using a modified version of the software and these modifications
may introduce extra bugs (or behavior changes). It is also patched for
stable releases instead of switching to new releases. The revision should
therefore be added to the version number to make it easier understandable
which modified version the user may have installed.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile

index 97f8cb149e4bc84283905f11d83cae452a662bd6..69e800a85f9a76addc37b04553ad2f062060d634 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2018.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_HASH:=b866b28dbbe5c9238abbdf5abbc30fc526dea56898ce4c1bd76d5c017843048b
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -69,7 +69,8 @@ NOSTDINC_FLAGS = \
        -I$(STAGING_DIR)/usr/include/mac80211/uapi \
        -I$(PKG_BUILD_DIR)/include/ \
        -include backport/backport.h \
-       -include $(PKG_BUILD_DIR)/compat-hacks.h
+       -include $(PKG_BUILD_DIR)/compat-hacks.h \
+       -DBATADV_SOURCE_VERSION=\\\"openwrt-$(PKG_VERSION)-$(PKG_RELEASE)\\\"
 
 COMPAT_SOURCES = \
        $(if $(CONFIG_KMOD_BATMAN_ADV_MCAST),../../compat-sources/net/core/skbuff.o,) \