cjdns: bump v21.1 and patch find-python (#883)
authorWilliam Fleurant <meshnet@protonmail.com>
Sat, 18 Jun 2022 17:01:00 +0000 (19:01 +0200)
committerGitHub <noreply@github.com>
Sat, 18 Jun 2022 17:01:00 +0000 (19:01 +0200)
* cjdns: bump source from v21 to v21.1
* cjdns: bump release with patch to prefer python2
* cjdns: refresh patches and remove patch musl

Signed-off-by: William Fleurant <meshnet@protonmail.com>
cjdns/Makefile
cjdns/patches/001-five-mins-builder-zonk.patch
cjdns/patches/010-musl-12x.patch [deleted file]
cjdns/patches/020-prefer-python2.patch [new file with mode: 0644]

index 61ecf926c2820f569ab63428e43f9354fbbd1278..b926bc7ba20df38737a4ca33e2279cb6d5f42faa 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cjdns
-PKG_VERSION:=v21
+PKG_VERSION:=v21.1
 PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/cjdelisle/cjdns/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
-PKG_HASH:=6dfb1fe18c9689324f36c8d33e660972aac5af4579fcaa9c4730179bc8d67c69
+PKG_HASH:=a6158ce7847159aa44e86f74ccc7b6ded6910a230ed8f3830db53cda5838f0b0
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
index 3128fb8bd2429b5a35b764c7d7d349699c644ac0..c53c62f4d7abceb20f9ce7c311774c6cc0170af1 100644 (file)
@@ -1,13 +1,13 @@
 --- a/node_build/builder.js
 +++ b/node_build/builder.js
-@@ -215,8 +215,8 @@ var execJs = function (js, builder, file
-     js = qs.join("'");
+@@ -277,8 +277,8 @@ const execJs = function (js, ctx, file,
+     js = '"use strict";' + qs.join("'");
  
-     var to = setTimeout(function () {
+     const to = setTimeout(function () {
 -        throw new Error("Inline JS did not return after 120 seconds [" + js + "]");
 -    }, 120000);
 +        throw new Error("Inline JS did not return after 5 minutes [" + js + "]");
 +    }, 300000);
  
-     var REQUIRE = function (str) {
-         if (typeof(str) !== 'string') {
+     nThen(function (waitFor) {
diff --git a/cjdns/patches/010-musl-12x.patch b/cjdns/patches/010-musl-12x.patch
deleted file mode 100644 (file)
index d82a144..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/memory/Allocator.c
-+++ b/memory/Allocator.c
-@@ -57,7 +57,7 @@ static void unroll(struct Allocator_pvt*
-     struct Allocator_Allocation_pvt* allocation = context->allocations;
-     while (allocation && includeAllocations) {
-         writeUnroller(&childUnroller);
--        fprintf(stderr, "%s:%ld [%lu] bytes at [0x%lx]\n",
-+        fprintf(stderr, "%s:%tu [%tu] bytes at [0x%lx]\n",
-                 allocation->fileName,
-                 allocation->lineNum,
-                 allocation->pub.size,
diff --git a/cjdns/patches/020-prefer-python2.patch b/cjdns/patches/020-prefer-python2.patch
new file mode 100644 (file)
index 0000000..5bb8624
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/node_build/FindPython.js
++++ b/node_build/FindPython.js
+@@ -23,7 +23,7 @@ var Fs = require('fs');
+ // de-prioritize because the testing script accepts ANY python3 version
+ // (as of this writing, we don't know what python3 versions actually work)
+ // whereas we know that python2.7 is the only working python2 version.
+-var PYTHONS = ["python3.7", "python3", "python2.7", "python2", "python"];
++var PYTHONS = ["python2", "python2.7", "python3.7", "python3.8", "python3.9", "python3"]
+ var SCRIPT = [
+     'import sys',