smcroute: Add package for version 2.0.0. 62/head
authorLeonardo Brondani Schenkel <leonardo@schenkel.net>
Mon, 3 Nov 2014 20:18:05 +0000 (20:18 +0000)
committerLeonardo Brondani Schenkel <leonardo@schenkel.net>
Mon, 3 Nov 2014 20:23:30 +0000 (20:23 +0000)
Signed-off-by: Leonardo Brondani Schenkel <leonardo@schenkel.net>
smcroute/Makefile [new file with mode: 0644]
smcroute/files/smcroute.init [new file with mode: 0644]

diff --git a/smcroute/Makefile b/smcroute/Makefile
new file mode 100644 (file)
index 0000000..523afb3
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=smcroute
+PKG_VERSION:=2.0.0
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0+
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=ftp://troglobit.com/smcroute/
+PKG_MD5SUM:=cbf478e52ab9ae411adca41b9d22f68a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/smcroute
+       SECTION:=net
+       CATEGORY:=Network
+       SUBMENU:=Routing and Redirection
+       TITLE:=Static Multicast Routing Daemon
+       URL:=http://troglobit.com/smcroute.html
+       MAINTAINER:=Leonardo Brondani Schenkel <leonardo@schenkel.net>
+endef
+
+define Package/smcroute/description
+       SMCRoute is a command line tool to manipulate the multicast routes of the Linux kernel.
+endef
+
+ifeq ($(HOST_OS),FreeBSD)
+       TARGET_CFLAGS += -fno-builtin-log
+       TARGET_LDFLAGS += -fno-builtin-log
+endif
+
+define Build/Compile
+       $(MAKE) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" -C $(PKG_BUILD_DIR) all
+endef
+
+define Package/smcroute/conffiles
+       /etc/smcproxy.conf
+endef
+
+define Package/smcroute/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/smcroute $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mcsender $(1)/usr/bin/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/smcroute.conf $(1)/etc
+       $(INSTALL_BIN) ./files/smcroute.init $(1)/etc/init.d/smcroute
+endef
+
+$(eval $(call BuildPackage,smcroute))
diff --git a/smcroute/files/smcroute.init b/smcroute/files/smcroute.init
new file mode 100644 (file)
index 0000000..3e36272
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2010 OpenWrt.org
+START=50
+
+start() {
+       smcroute -d
+}
+
+stop() {
+       smcroute -k
+}