batman-adv: Switch proto scripts to new prefixes
authorSven Eckelmann <sven@narfation.org>
Thu, 1 Aug 2019 14:22:00 +0000 (16:22 +0200)
committerSven Eckelmann <sven@narfation.org>
Thu, 1 Aug 2019 15:45:46 +0000 (17:45 +0200)
The '-m' option to select the mesh interface or vlan interfaces was
replaced with device type specific subcommand prefixes:

* meshif <netdev>
* vlan <vdev>
* meshif <netdev> vid <vid>
* hardif <netdev>

This change should also be made in the proto script to allow batctl to drop
the support of '-m' completely in the future.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile
batman-adv/files/lib/netifd/proto/batadv.sh
batman-adv/files/lib/netifd/proto/batadv_hardif.sh
batman-adv/files/lib/netifd/proto/batadv_vlan.sh

index e689d72516798e8137985685b8b76db8fea34dd8..6b831c75f255a0bff1068bcbeb001c96a9425181 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2019.2
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_HASH:=70c3f6a6cf88d2b25681a76768a52ed92d9fe992ba8e358368b6a8088757adc8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index a7fe63cd8f45ebd2a6d3c2841e805ff8b8fe930e..edc14f4cbd5485ede408e897fada8eae6f8f09d3 100755 (executable)
@@ -72,42 +72,42 @@ proto_batadv_setup() {
        set_default routing_algo 'BATMAN_IV'
 
        batctl routing_algo "$routing_algo"
-       batctl -m "$iface" interface create
+       batctl meshif "$iface" interface create
 
-       [ -n "$aggregated_ogms" ] && batctl -m "$iface" aggregation "$aggregated_ogms"
-       [ -n "$ap_isolation" ] && batctl -m "$iface" ap_isolation "$ap_isolation"
-       [ -n "$bonding" ] && batctl -m "$iface" bonding "$bonding"
-       [ -n "$bridge_loop_avoidance" ] &&  batctl -m "$iface" bridge_loop_avoidance "$bridge_loop_avoidance" 2>&-
-       [ -n "$distributed_arp_table" ] && batctl -m "$iface" distributed_arp_table "$distributed_arp_table" 2>&-
-       [ -n "$fragmentation" ] && batctl -m "$iface" fragmentation "$fragmentation"
+       [ -n "$aggregated_ogms" ] && batctl meshif "$iface" aggregation "$aggregated_ogms"
+       [ -n "$ap_isolation" ] && batctl meshif "$iface" ap_isolation "$ap_isolation"
+       [ -n "$bonding" ] && batctl meshif "$iface" bonding "$bonding"
+       [ -n "$bridge_loop_avoidance" ] &&  batctl meshif "$iface" bridge_loop_avoidance "$bridge_loop_avoidance" 2>&-
+       [ -n "$distributed_arp_table" ] && batctl meshif "$iface" distributed_arp_table "$distributed_arp_table" 2>&-
+       [ -n "$fragmentation" ] && batctl meshif "$iface" fragmentation "$fragmentation"
 
        case "$gw_mode" in
        server)
                if [ -n "$gw_bandwidth" ]; then
-                       batctl -m "$iface" gw_mode "server" "$gw_bandwidth"
+                       batctl meshif "$iface" gw_mode "server" "$gw_bandwidth"
                else
-                       batctl -m "$iface" gw_mode "server"
+                       batctl meshif "$iface" gw_mode "server"
                fi
                ;;
        client)
                if [ -n "$gw_sel_class" ]; then
-                       batctl -m "$iface" gw_mode "client" "$gw_sel_class"
+                       batctl meshif "$iface" gw_mode "client" "$gw_sel_class"
                else
-                       batctl -m "$iface" gw_mode "client"
+                       batctl meshif "$iface" gw_mode "client"
                fi
                ;;
        *)
-               batctl -m "$iface" gw_mode "off"
+               batctl meshif "$iface" gw_mode "off"
                ;;
        esac
 
-       [ -n "$hop_penalty" ] && batctl -m "$iface" hop_penalty "$hop_penalty"
-       [ -n "$isolation_mark" ] && batctl -m "$iface" isolation_mark "$isolation_mark"
-       [ -n "$multicast_fanout" ] && batctl -m "$iface" multicast_fanout "$multicast_fanout"
-       [ -n "$multicast_mode" ] && batctl -m "$iface" multicast_mode "$multicast_mode" 2>&-
-       [ -n "$network_coding" ] && batctl -m "$iface" network_coding "$network_coding" 2>&-
-       [ -n "$log_level" ] && batctl -m "$iface" loglevel "$log_level" 2>&-
-       [ -n "$orig_interval" ] && batctl -m "$iface" orig_interval "$orig_interval"
+       [ -n "$hop_penalty" ] && batctl meshif "$iface" hop_penalty "$hop_penalty"
+       [ -n "$isolation_mark" ] && batctl meshif "$iface" isolation_mark "$isolation_mark"
+       [ -n "$multicast_fanout" ] && batctl meshif "$iface" multicast_fanout "$multicast_fanout"
+       [ -n "$multicast_mode" ] && batctl meshif "$iface" multicast_mode "$multicast_mode" 2>&-
+       [ -n "$network_coding" ] && batctl meshif "$iface" network_coding "$network_coding" 2>&-
+       [ -n "$log_level" ] && batctl meshif "$iface" loglevel "$log_level" 2>&-
+       [ -n "$orig_interval" ] && batctl meshif "$iface" orig_interval "$orig_interval"
 
        proto_init_update "$iface" 1
        proto_send_update "$config"
@@ -117,7 +117,7 @@ proto_batadv_teardown() {
        local config="$1"
        local iface="$config"
 
-       batctl -m "$iface" interface destroy
+       batctl meshif "$iface" interface destroy
 }
 
 add_protocol batadv
index 76ccd8199e44f5dc3f485f343f7ee91495631b67..6eb597ff610683ce4d478e83d4515fe518228329 100755 (executable)
@@ -26,10 +26,10 @@ proto_batadv_hardif_setup() {
 
        ( proto_add_host_dependency "$config" '' "$master" )
 
-       batctl -m "$master" interface -M add "$iface"
+       batctl meshif "$master" interface -M add "$iface"
 
-       [ -n "$elp_interval" ] && batctl -m "$master" hardif "$iface" elp_interval "$elp_interval"
-       [ -n "$throughput_override" ] && batctl -m "$master" hardif "$iface" throughput_override "$throughput_override"
+       [ -n "$elp_interval" ] && batctl hardif "$iface" elp_interval "$elp_interval"
+       [ -n "$throughput_override" ] && batctl hardif "$iface" throughput_override "$throughput_override"
 
        proto_init_update "$iface" 1
        proto_send_update "$config"
@@ -43,7 +43,7 @@ proto_batadv_hardif_teardown() {
 
        json_get_vars master
 
-       batctl -m "$master" interface -M del "$iface" || true
+       batctl meshif "$master" interface -M del "$iface" || true
 }
 
 add_protocol batadv_hardif
index b4835f6d703c97da34f95caf94bfef9ea0ff9963..115e61cde75137d62f236fe6391b696ad76e307e 100755 (executable)
@@ -17,7 +17,7 @@ proto_batadv_vlan_setup() {
 
        json_get_vars ap_isolation
 
-       [ -n "$ap_isolation" ] && batctl -m "$iface" ap_isolation "$ap_isolation"
+       [ -n "$ap_isolation" ] && batctl vlan "$iface" ap_isolation "$ap_isolation"
        proto_init_update "$iface" 1
        proto_send_update "$config"
 }