Merge pull request #10 from mmunz/upstream
authorBastian Bittorf <bittorf@bluebottle.com>
Thu, 14 Nov 2013 08:36:08 +0000 (00:36 -0800)
committerBastian Bittorf <bittorf@bluebottle.com>
Thu, 14 Nov 2013 08:36:08 +0000 (00:36 -0800)
Fix config creation for multiple LinkQualityMult entries in uci config

alfred/Config.in
alfred/Makefile
alfred/files/bat-hosts.lua [new file with mode: 0644]
olsrd/files/olsrd.hotplug.sh

index 1791949734ead566312e9014b4ff732c94458120..97f9ea21f8b67ad8266462d36a2a203b0f78e0ae 100644 (file)
@@ -1,3 +1,6 @@
+config ALFRED_NEEDS_lua
+       bool
+
 config ALFRED_NEEDS_libgps
        bool
 
@@ -6,6 +9,12 @@ config PACKAGE_ALFRED_VIS
        depends on PACKAGE_alfred
        default y
 
+config PACKAGE_ALFRED_BATHOSTS
+       bool "enable autogeneration of /etc/bat-hosts"
+       depends on PACKAGE_alfred
+       select ALFRED_NEEDS_lua
+       default n
+
 config PACKAGE_ALFRED_GPSD
        bool "enable gpsd service for alfred"
        depends on PACKAGE_alfred
index 67be82fc464195eafd99a0dc4c0b97c24b2c0799..ffc80267066bdc05a74e15581885acc3eceff927 100644 (file)
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
 #
 PKG_NAME:=alfred
 PKG_VERSION:=2013.4.0
-PKG_RELEASE:=0
+PKG_RELEASE:=1
 PKG_MD5SUM:=3891697e127b1037cfc9349fd96e9993
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -28,6 +28,7 @@ define Package/alfred
   CATEGORY:=Network
   TITLE:=A.L.F.R.E.D. - Almighty Lightweight Fact Remote Exchange Daemon
   DEPENDS:= +libc +IPV6:kmod-ipv6 +librt \
+         +ALFRED_NEEDS_lua:lua \
          +ALFRED_NEEDS_libgps:libgps
 endef
 
@@ -77,6 +78,8 @@ define Package/alfred/install
        $(INSTALL_BIN) ./files/alfred.init $(1)/etc/init.d/alfred
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/alfred.config $(1)/etc/config/alfred
+       $(INSTALL_DIR) $(1)/etc/alfred
+       [ "x$(CONFIG_PACKAGE_ALFRED_BATHOSTS)" == "xy" ] && $(INSTALL_BIN) ./files/bat-hosts.lua $(1)/etc/alfred/bat-hosts.lua ; true
 endef
 
 $(eval $(call BuildPackage,alfred))
diff --git a/alfred/files/bat-hosts.lua b/alfred/files/bat-hosts.lua
new file mode 100644 (file)
index 0000000..8648caf
--- /dev/null
@@ -0,0 +1,107 @@
+#!/usr/bin/lua
+
+local type_id = 64 -- bat-hosts
+
+function get_hostname()
+  local hostfile = io.open("/proc/sys/kernel/hostname", "r")
+  local ret_string = hostfile:read()
+  hostfile:close()
+  return ret_string
+end
+
+function get_interfaces_names()
+  local ret = {}
+
+  for name in io.popen("ls -1 /sys/class/net/"):lines() do
+    table.insert(ret, name)
+  end
+
+  return ret
+end
+
+function get_interface_address(name)
+  local addressfile = io.open("/sys/class/net/"..name.."/address", "r")
+  local ret_string = addressfile:read()
+  addressfile:close()
+  return ret_string
+end
+
+
+local function generate_bat_hosts()
+-- get hostname and interface macs/names
+-- then return a table containing valid bat-hosts lines
+  local n, i
+  local ifaces, ret = {}, {}
+
+  local hostname = get_hostname()
+
+  for n, i in ipairs(get_interfaces_names()) do
+    local address = get_interface_address(i)
+    if not ifaces[address] then ifaces[address] = i end
+  end
+
+  for mac, iname in pairs(ifaces) do
+    if mac:match("^%x%x:%x%x:%x%x:%x%x:%x%x:%x%x$") and not mac:match("00:00:00:00:00:00") then
+      table.insert(ret, mac.." "..hostname.."_"..iname.."\n")
+    end
+  end
+
+  return ret
+end
+
+local function publish_bat_hosts()
+-- pass a raw chunk of data to alfred
+  local fd = io.popen("alfred -s " .. type_id, "w")
+  if fd then
+    local ret = generate_bat_hosts()
+    if ret then
+      fd:write(table.concat(ret))
+    end
+    fd:close()
+  end
+end
+
+local function write_bat_hosts(rows)
+  local content = { "### /tmp/bat-hosts generated by alfred-bat-hosts\n",
+                    "### /!\\ This file is overwritten every 5 minutes /!\\\n",
+                    "### (To keep manual changes, replace /etc/bat-hosts symlink with a static file)\n" }
+
+  -- merge the chunks from all nodes, de-escaping newlines
+  for _, row in ipairs(rows) do
+    local node, value = unpack(row)
+    table.insert(content, "# Node ".. node .. "\n")
+    table.insert(content, value:gsub("\x0a", "\n") .. "\n")
+  end
+
+  -- write parsed content down to disk
+  local fd = io.open("/tmp/bat-hosts", "w")
+  if fd then
+    fd:write(table.concat(content))
+    fd:close()
+  end
+
+  -- try to make a symlink in /etc pointing to /tmp,
+  -- if it exists, ln will do nothing.
+  os.execute("ln -ns /tmp/bat-hosts /etc/bat-hosts 2>/dev/null")
+end
+
+local function receive_bat_hosts()
+-- read raw chunks from alfred, convert them to a nested table and call write_bat_hosts
+  local fd = io.popen("alfred -r " .. type_id)
+    --[[ this command returns something like
+    { "54:e6:fc:b9:cb:37", "00:11:22:33:44:55 ham_wlan0\x0a00:22:33:22:33:22 ham_eth0\x0a" },
+    { "90:f6:52:bb:ec:57", "00:22:33:22:33:23 spam\x0a" },
+    ]]--
+
+  if fd then
+    local output = fd:read("*a")
+    if output then
+      assert(loadstring("rows = {" .. output .. "}"))()
+      write_bat_hosts(rows)
+    end
+    fd:close()
+  end
+end
+
+publish_bat_hosts()
+receive_bat_hosts()
index 6d1641fa0689ffad75e004ff6804214f04f24c17..db709a8155162896428d3dc4d50382b9ccec9c47 100755 (executable)
@@ -44,9 +44,11 @@ olsrd_interface_needs_adding()
 
 case "$ACTION" in
        ifup)
-               /etc/init.d/olsrd enabled && {
+               # only work after the first normal startup
+               # also: no need to test, if enabled
+               [ -e '/var/run/olsrd.pid' ] && {
                        olsrd_interface_needs_adding "$INTERFACE" "$DEVICE" && {
-                               /etc/init.d/olsrd restart
+                               . /etc/rc.common /etc/init.d/olsrd restart
                        }
                }
        ;;