batctl: upgrade package to latest release 2019.0
authorSven Eckelmann <sven@narfation.org>
Sun, 27 Jan 2019 15:28:23 +0000 (16:28 +0100)
committerSven Eckelmann <sven@narfation.org>
Sat, 2 Feb 2019 13:04:09 +0000 (14:04 +0100)
* coding style cleanups and refactoring
* add gateway selection manpage section for B.A.T.M.A.N. V
* bugs squashed:

  - re-integrate support for translation table unicast/multicast filter
  - avoid incorrect warning about disabled mesh interface when debugfs
    support is not enabled in batman-adv

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batctl/Makefile
batctl/patches/0001-batctl-Fix-parsing-of-optional-debug-table-command-p.patch [deleted file]

index 9eefe864801e86fb9d7dfedad10832b00d78f591..0284c794a15bf26a75b3522387da587456195633 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batctl
 
-PKG_VERSION:=2018.4
-PKG_RELEASE:=3
-PKG_HASH:=e43827a5e868b4e134e77ca04da989fde1981463166bf1b6f2053acc3edd6257
+PKG_VERSION:=2019.0
+PKG_RELEASE:=0
+PKG_HASH:=997721096ff396644e8d697ea7651e9d38243faf317bcea2661d4139ff58b531
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
diff --git a/batctl/patches/0001-batctl-Fix-parsing-of-optional-debug-table-command-p.patch b/batctl/patches/0001-batctl-Fix-parsing-of-optional-debug-table-command-p.patch
deleted file mode 100644 (file)
index 559d2ed..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-From: Sven Eckelmann <sven@narfation.org>
-Date: Thu, 6 Dec 2018 07:31:59 +0100
-Subject: [PATCH] batctl: Fix parsing of optional debug table command parameters
-
-The commands which should have no support for -t/-u/-m/-i were allowed to
-accept these parameters but commands which should have accepted them were
-denying them.
-
-Fixes: cd2b4047ead9 ("batctl: Convert debug table to command infrastructure")
-Reported-by: Andreas Ziegler <dev@andreas-ziegler.de>
-Signed-off-by: Sven Eckelmann <sven@narfation.org>
-
-Forwarded: https://patchwork.open-mesh.org/patch/17667/
----
- debug.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/debug.c b/debug.c
-index 2979dff99af0b1c98f56931e8650e298dd9eac9b..316312f7162dbe0dc38ced2df1444887482e7bad 100644
---- a/debug.c
-+++ b/debug.c
-@@ -89,7 +89,7 @@ int handle_debug_table(struct state *state, int argc, char **argv)
-                       }
-                       break;
-               case 't':
--                      if (debug_table->option_watch_interval) {
-+                      if (!debug_table->option_watch_interval) {
-                               fprintf(stderr, "Error - unrecognised option '-%c'\n", optchar);
-                               debug_table_usage(state);
-                               return EXIT_FAILURE;
-@@ -105,7 +105,7 @@ int handle_debug_table(struct state *state, int argc, char **argv)
-                       read_opt |= SKIP_HEADER;
-                       break;
-               case 'u':
--                      if (debug_table->option_unicast_only) {
-+                      if (!debug_table->option_unicast_only) {
-                               fprintf(stderr, "Error - unrecognised option '-%c'\n", optchar);
-                               debug_table_usage(state);
-                               return EXIT_FAILURE;
-@@ -114,7 +114,7 @@ int handle_debug_table(struct state *state, int argc, char **argv)
-                       read_opt |= UNICAST_ONLY;
-                       break;
-               case 'm':
--                      if (debug_table->option_multicast_only) {
-+                      if (!debug_table->option_multicast_only) {
-                               fprintf(stderr, "Error - unrecognised option '-%c'\n", optchar);
-                               debug_table_usage(state);
-                               return EXIT_FAILURE;
-@@ -123,7 +123,7 @@ int handle_debug_table(struct state *state, int argc, char **argv)
-                       read_opt |= MULTICAST_ONLY;
-                       break;
-               case 'i':
--                      if (debug_table->option_orig_iface) {
-+                      if (!debug_table->option_orig_iface) {
-                               fprintf(stderr, "Error - unrecognised option '-%c'\n", optchar);
-                               debug_table_usage(state);
-                               return EXIT_FAILURE;