cjdns: always build without ccache prefix
authorWilliam Fleurant <meshnet@protonmail.com>
Sun, 29 Oct 2023 09:05:17 +0000 (10:05 +0100)
committerGitHub <noreply@github.com>
Sun, 29 Oct 2023 09:05:17 +0000 (10:05 +0100)
Signed-off-by: William Fleurant <meshnet@protonmail.com>
cjdns/Makefile

index 1f8592b60eb1fb66164decf7823e06e79a516f52..3cffe1a6f20df6267c7e27623f1948c934312c63 100644 (file)
@@ -18,7 +18,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cjdns
 PKG_VERSION:=v21.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/cjdelisle/cjdns/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
@@ -78,7 +78,7 @@ define Build/Compile
        $(INSTALL_DIR) $(PKG_BUILD_DIR)/tmp
        (cd $(PKG_BUILD_DIR) && \
        CROSS="true" \
-       CC="$(TARGET_CC)" \
+       CC="$(TARGET_CC_NOCACHE)" \
        AR="$(TARGET_AR)" \
        RANLIB="$(TARGET_RANLIB)" \
        CFLAGS="$(TARGET_CFLAGS) -U_FORTIFY_SOURCE -Wno-error=array-bounds -Wno-error=stringop-overflow -Wno-error=stringop-overread" \