batman-adv: compat: Fix skb_vlan_eth_hdr conflict in stable kernels 1038/head
authorSven Eckelmann <sven@narfation.org>
Sat, 23 Dec 2023 10:55:49 +0000 (11:55 +0100)
committerSven Eckelmann <sven@narfation.org>
Sat, 23 Dec 2023 14:33:57 +0000 (15:33 +0100)
The newest Linux stable kernel releases:

* v5.10.205
* v5.15.144
* v6.1.69

received a backported version of commit 1f5020acb33f ("net: vlan: introduce
skb_vlan_eth_hdr()"). batman-adv must therefore not provide this function
any longer for these kernel versions.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile
batman-adv/src/compat-hacks.h

index ea48f3a0a94bdd484d9db95b44ddd6c064534e02..71e98e2dee8a77ffca9114bb212e47a7544142cb 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
 PKG_VERSION:=2023.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
index fcf7b936c7b11a3bd031f61798106706a2cdda47..364e312e039e03469cde3f9e6e08c0ed5e2125f8 100644 (file)
@@ -28,7 +28,10 @@ static inline u32 batadv_get_random_u32_below(u32 ep_ro)
 
 #endif /* LINUX_VERSION_IS_LESS(6, 2, 0) */
 
-#if LINUX_VERSION_IS_LESS(6, 4, 0)
+#if LINUX_VERSION_IS_LESS(6, 4, 0) && \
+    !(LINUX_VERSION_IS_GEQ(5, 10, 205) && LINUX_VERSION_IS_LESS(5, 11, 0)) && \
+    !(LINUX_VERSION_IS_GEQ(5, 15, 144) && LINUX_VERSION_IS_LESS(5, 16, 0)) && \
+    !(LINUX_VERSION_IS_GEQ(6, 1, 69) && LINUX_VERSION_IS_LESS(6, 2, 0))
 
 #include <linux/if_vlan.h>