batman-adv: Re-add kmod-lib-crc16 back to dependency line
authorSven Eckelmann <sven@narfation.org>
Mon, 22 Oct 2018 10:24:10 +0000 (12:24 +0200)
committerSven Eckelmann <sven@narfation.org>
Mon, 22 Oct 2018 10:34:32 +0000 (12:34 +0200)
The OpenWrt dependency builder cannot extract the crc16 dependency from
the KMOD_BATMAN_ADV_BLA dependencies. They have to be specified directly in
the OpenWrt Makefile's DEPENDS line to avoid error when BLA is enabled:

  Package kmod-batman-adv is missing dependencies for the following libraries:
  crc16.ko

Reported-by: Lech Perczak <lech.perczak@gmail.com>
Fixes: 0db66160aaab ("batman-adv: Sync config options with kernel Kconfig")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile

index 36c764e125f31ed5d476349855e2a3e24cf5f17c..898efe3e1ac8581b55167c81c139e889d0a13aca 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2018.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_HASH:=33f3f942203732e0568a6bc0226a0fe8eb147c961f0d0c13b2e6b16237d412ff
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -27,7 +27,7 @@ define KernelPackage/batman-adv
   URL:=https://www.open-mesh.org/
   MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
   SUBMENU:=Network Support
-  DEPENDS:=+kmod-lib-crc32c +kmod-cfg80211
+  DEPENDS:=+BATMAN_ADV_BLA:kmod-lib-crc16 +kmod-lib-crc32c +kmod-cfg80211
   TITLE:=B.A.T.M.A.N. Adv
   FILES:=$(PKG_BUILD_DIR)/net/batman-adv/batman-adv.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoProbe,batman-adv)