bmx6: drop package
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 28 Sep 2023 07:31:02 +0000 (09:31 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 29 Sep 2023 08:19:54 +0000 (10:19 +0200)
This package is no longer maintained by us or by upstream developers.
The last version in the GitHub repository is from 2020 with no activity so far.
We are using version 0.1-alpha.

Because LuCI app is vulnerable to several CVEs and DependencyBot still
sends emails about it, let's drop it.

If anyone wants, they can use bmx7.

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
bmx6/Makefile [deleted file]
bmx6/files/etc/config/bmx6 [deleted file]
bmx6/files/etc/init.d/bmx6 [deleted file]
bmx6/patches/010-siocgstamp.patch [deleted file]

diff --git a/bmx6/Makefile b/bmx6/Makefile
deleted file mode 100644 (file)
index b533196..0000000
+++ /dev/null
@@ -1,150 +0,0 @@
-#    Copyright (C) 2011 Fundacio Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net
-#
-#    This program is free software; you can redistribute it and/or modify
-#    it under the terms of the GNU General Public License as published by
-#    the Free Software Foundation; either version 2 of the License, or
-#    (at your option) any later version.
-#
-#    This program is distributed in the hope that it will be useful,
-#    but WITHOUT ANY WARRANTY; without even the implied warranty of
-#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#    GNU General Public License for more details.
-#
-#    You should have received a copy of the GNU General Public License along
-#    with this program; if not, write to the Free Software Foundation, Inc.,
-#    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-#    The full GNU General Public License is included in this distribution in
-#    the file called "COPYING".
-#
-# Contibutors:
-#      Axel Neumann, Simó Albert i Beltran, Pau Escrich
-#
-
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bmx6
-PKG_VERSION:=0.1-alpha
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/bmx-routing/bmx6.git
-PKG_SOURCE_DATE:=2020-06-08
-PKG_SOURCE_VERSION:=65cb0d542f16a4b4689f5ad2542c9f24215a6616
-PKG_MIRROR_HASH:=45501cfe9f82e08e8082147f90b94ba5b6bd11771a9140412bfbf5523a796177
-
-PKG_MAINTAINER:=Axel Neumann <neumann@cgws.de>
-PKG_LICENSE:=GPL-2.0-or-later
-
-include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS += $(FPIC)
-
-MAKE_ARGS += \
-       EXTRA_CFLAGS="$(TARGET_CFLAGS) -I. -I$(STAGING_DIR)/usr/include -DNO_DEBUG_ALL -DNO_DEBUG_DUMP" \
-       EXTRA_LDFLAGS="-L$(STAGING_DIR)/usr/lib " \
-       GIT_REV="$(PKG_REV)" \
-       CC="$(TARGET_CC)" \
-       INSTALL_DIR="$(PKG_INSTALL_DIR)" \
-       STRIP="/bin/false" \
-       build_all
-
-define Package/bmx6/Default
-  SECTION:=net
-  CATEGORY:=Network
-  SUBMENU:=Routing and Redirection
-  TITLE:=BMX6 layer 3 routing daemon
-  URL:=https://bmx6.net/projects/bmx6
-  DEPENDS:=+kmod-ip6-tunnel +kmod-iptunnel6 +kmod-tun
-endef
-
-define Package/bmx6/description
-BMX6 layer 3 routing daemon supporting IPv4, IPv6, and IPv4 over IPv6
-endef
-
-define Package/bmx6
-  $(call Package/bmx6/Default)
-  MENU:=1
-endef
-
-define Package/bmx6-uci-config
-  $(call Package/bmx6/Default)
-  DEPENDS:=bmx6 +libuci
-  TITLE:=configuration plugin based on uci (recommended!)
-endef
-
-define Package/bmx6-json
-  $(call Package/bmx6/Default)
-  DEPENDS:=bmx6 +libjson-c
-  TITLE:=json plugin based on json-c
-endef
-
-define Package/bmx6-sms
-  $(call Package/bmx6/Default)
-  DEPENDS:=bmx6
-  TITLE:=sms plugin
-endef
-
-#define Package/bmx6-quagga
-#  $(call Package/bmx6/Default)
-#  DEPENDS:=bmx6 +qmp-quagga @BROKEN
-#  TITLE:=bmx6 quagga plugin to redistribute/export routes (needs manet/bmx6 patched quagga 0.99.21)
-#endef
-
-define Package/bmx6-table
-  $(call Package/bmx6/Default)
-  DEPENDS:=bmx6
-  TITLE:=bmx6 table plugin to automatic announce routing-table routes via ip6ip tunnels
-endef
-
-define Build/Configure
-       mkdir -p $(PKG_INSTALL_DIR)
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS)
-endef
-
-define Package/bmx6/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bmx6 $(1)/usr/sbin/bmx6
-endef
-
-define Package/bmx6-uci-config/conffiles
-/etc/config/bmx6
-endef
-
-define Package/bmx6-uci-config/install
-       $(INSTALL_DIR) $(1)/usr/lib $(1)/etc/config $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_uci_config/bmx6_config.so $(1)/usr/lib/bmx6_config.so
-       $(INSTALL_BIN) ./files/etc/init.d/bmx6 $(1)/etc/init.d/bmx6
-       $(INSTALL_DATA) ./files/etc/config/bmx6 $(1)/etc/config/bmx6
-endef
-
-define Package/bmx6-json/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_json/bmx6_json.so $(1)/usr/lib/bmx6_json.so
-endef
-
-define Package/bmx6-sms/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_sms/bmx6_sms.so $(1)/usr/lib/bmx6_sms.so
-endef
-
-define Package/bmx6-table/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_table/bmx6_table.so $(1)/usr/lib/bmx6_table.so
-endef
-
-#define Package/bmx6-quagga/install
-#      $(INSTALL_DIR) $(1)/usr/lib
-#      $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_quagga/bmx6_quagga.so $(1)/usr/lib/bmx6_quagga.so
-#endef
-
-$(eval $(call BuildPackage,bmx6))
-$(eval $(call BuildPackage,bmx6-uci-config))
-$(eval $(call BuildPackage,bmx6-json))
-$(eval $(call BuildPackage,bmx6-sms))
-#$(eval $(call BuildPackage,bmx6-quagga))
-$(eval $(call BuildPackage,bmx6-table))
diff --git a/bmx6/files/etc/config/bmx6 b/bmx6/files/etc/config/bmx6
deleted file mode 100644 (file)
index 884fd12..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-
-# for more information:
-# http://bmx6.net/projects/bmx6/wiki
-# options execute: bmx6 --help
-
-config 'bmx6' 'general'
-#       option 'runtimeDir' '/var/run/bmx6'
-#       option 'tun4Address' '10.202.0.116/32'
-#       option 'tun4Address' '10.254.10.0/32'
-#       option 'tun6Address' '2012:0:0:1000::1/64'
-
-#config 'ipVersion' 'ipVersion'
-#       option 'ipVersion' '6'   # default is 4
-#       option 'throwRules' '0'
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_config.so'
-
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_json.so'
-
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_sms.so'
-
-
-config 'dev' 'mesh_1'
-        option 'dev' 'eth0.12'
-
-config 'dev' 'mesh_2'
-        option 'dev' 'ath0.12'
-
-
-
-#config 'hna' 'my_global_prefix'
-#       option 'hna' '2012:0:0:74:0:0:0:0/64'
-
-
-#config 'tunOut'
-#        option 'tunOut' 'ip6'
-#        option 'network' '2012::/16'
-#        option 'exportDistance' '0'
-
-#config 'tunOut'
-#        option 'tunOut' 'ip4'
-#        option 'network' '10.254.0.0/16'
-#        option 'exportDistance' '0'  # requires quagga plugin !
-#        option 'minPrefixLen' '27'
-
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_quagga.so'
-
-
-
-#config 'redistribute'
-#        option 'redistribute' 'ospf6'
-#        option 'network' '10.0.0.0/8'
-#        option 'minPrefixLen' '10'
-#        option 'bandwidth' '10000000'
-#        option 'ospf6' '1'
-#        option 'aggregatePrefixLen' '16'
-
-#config 'redistribute'
-#        option 'redistribute' 'bgp'
-#        option 'network' '0.0.0.0/0'
-#        option 'minPrefixLen' '0'
-#        option 'maxPrefixLen' '24'
-#        option 'bandwidth' '10000000'
-#        option 'bgp' '1'
-#        option 'aggregatePrefixLen' '8'
-
-
-
-
-
-
diff --git a/bmx6/files/etc/init.d/bmx6 b/bmx6/files/etc/init.d/bmx6
deleted file mode 100755 (executable)
index 9d48eb4..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh /etc/rc.common
-#    Copyright (C) 2017 Gui Iribarren <gui@altermundi.net>
-#    Copyright (C) 2011 Fundacio Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net
-#
-#    This is free software, licensed under the GNU General Public License v3.
-
-START=91
-STOP=91
-USE_PROCD=1
-
-NAME=bmx6
-BIN=/usr/sbin/bmx6
-CONF=/etc/config/bmx6
-PID=/var/run/bmx6/pid
-DEBUG=0
-
-start_service() {
-    procd_open_instance "$NAME"
-    procd_set_param command "$BIN" -f "$CONF" -d "$DEBUG"
-
-    ### Respawn automatically when process dies, after waiting respawn_timeout seconds
-    ### If respawn_retry consecutives respawns die before respawn_threshold seconds (i.e. they crash)
-    ### it will stop trying and leave it dead.
-    procd_set_param respawn ${respawn_threshold:-60} ${respawn_timeout:-3} ${respawn_retry:-5}
-
-    procd_set_param limits core="20000"  # Equivalent to 'ulimit -c 20000'
-    procd_close_instance
-}
-
-reload_service() {
-    "$BIN" -c configReload
-}
-
-service_triggers()
-{
-    procd_add_reload_trigger "bmx6" # Call reload_service() when /etc/config/bmx6 changed and reload_config is run
-}
diff --git a/bmx6/patches/010-siocgstamp.patch b/bmx6/patches/010-siocgstamp.patch
deleted file mode 100644 (file)
index 10c2582..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/schedule.c
-+++ b/schedule.c
-@@ -356,7 +356,9 @@ loop4Event:
-                                       continue;
-                               }
-+#ifdef SIOCGSTAMP
-                               ioctl(pb.i.iif->rx_mcast_sock, SIOCGSTAMP, &(pb.i.tv_stamp)) ;
-+#endif
-                               
-                               rx_packet( &pb );
-                               
-@@ -381,8 +383,10 @@ loop4Event:
-                                       
-                                       continue;
-                               }
--                              
-+
-+#ifdef SIOCGSTAMP
-                               ioctl(pb.i.iif->rx_fullbrc_sock, SIOCGSTAMP, &(pb.i.tv_stamp)) ;
-+#endif
-                               
-                               rx_packet( &pb );
-                               
-@@ -432,10 +436,15 @@ loop4Event:
-                                       }
-                               }
- #endif
-+#ifdef SIOCGSTAMP
-                               if ( tv_stamp == NULL )
-                                       ioctl( pb.i.iif->unicast_sock, SIOCGSTAMP, &(pb.i.tv_stamp) );
-                               else
-                                       timercpy( tv_stamp, &(pb.i.tv_stamp) );
-+#else
-+                              if (tv_stamp)
-+                                      timercpy( tv_stamp, &(pb.i.tv_stamp) );
-+#endif
-                               
-                               rx_packet( &pb );
-