babels: bump and enable subtrees by default
authorSteven Barth <steven@midlink.org>
Tue, 21 Apr 2015 08:27:48 +0000 (10:27 +0200)
committerSteven Barth <steven@midlink.org>
Tue, 21 Apr 2015 08:27:48 +0000 (10:27 +0200)
Signed-off-by: Steven Barth <steven@midlink.org>
babels/Makefile
babels/patches/0001-Allow-routes-with-source-128-for-SAS-on-Linux.patch
babels/patches/0002-ipv6-subtrees-default-on.patch [new file with mode: 0644]

index 164ff1661d263deec2339d757170fe577d84cb88..57b723dd20609ead779c34bf7314bc38fb3ff917 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babels
-PKG_SOURCE_VERSION:=8950d3b2f9a4799f8435c7165998c638dd0a98a8
-PKG_VERSION:=2015-04-10-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=1ba29b3e069908d41fd6e263d0d09cd5a551a644
+PKG_VERSION:=2015-04-14-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/jech/babeld.git
index 7e9448c25e134db5e44201cd5f9db7da21eaa0fd..ffcb9879687b25484951de75485d4bfecf11f143 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
 
 --- a/kernel_netlink.c
 +++ b/kernel_netlink.c
-@@ -1242,8 +1242,8 @@ filter_kernel_routes(struct nlmsghdr *nh
+@@ -1243,8 +1243,8 @@ filter_kernel_routes(struct nlmsghdr *nh
      if(rc < 0)
          return 0;
  
@@ -35,7 +35,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
          return 0;
  
      /* Ignore default unreachable routes; no idea where they come from. */
-@@ -1944,7 +1944,7 @@ filter_kernel_rules(struct nlmsghdr *nh,
+@@ -1946,7 +1946,7 @@ filter_kernel_rules(struct nlmsghdr *nh,
      kdebugf("filter_rules: from %s prio %d table %d\n",
              format_prefix(src, src_plen), priority, table);
  
@@ -46,7 +46,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
      i = priority - src_table_prio;
 --- a/route.c
 +++ b/route.c
-@@ -901,12 +901,12 @@ update_route(const unsigned char *id,
+@@ -809,12 +809,12 @@ update_route(const unsigned char *id,
      if(memcmp(id, myid, 8) == 0)
          return NULL;
  
@@ -92,7 +92,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  void v4tov6(unsigned char *dst, const unsigned char *src);
 --- a/xroute.c
 +++ b/xroute.c
-@@ -266,7 +266,7 @@ check_xroutes(int send_updates)
+@@ -264,7 +264,7 @@ check_xroutes(int send_updates)
      /* Add any new routes */
  
      for(i = 0; i < numroutes; i++) {
diff --git a/babels/patches/0002-ipv6-subtrees-default-on.patch b/babels/patches/0002-ipv6-subtrees-default-on.patch
new file mode 100644 (file)
index 0000000..0cad972
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/babeld.c
++++ b/babeld.c
+@@ -60,7 +60,7 @@ int debug = 0;
+ int link_detect = 0;
+ int all_wireless = 0;
+-int has_ipv6_subtrees = 0;
++int has_ipv6_subtrees = 1;
+ int default_wireless_hello_interval = -1;
+ int default_wired_hello_interval = -1;
+ int resend_delay = -1;