batman-adv: Fix search for cfg80211 module symbols
authorSven Eckelmann <sven@narfation.org>
Sun, 7 Oct 2018 11:20:30 +0000 (13:20 +0200)
committerSven Eckelmann <sven@narfation.org>
Sun, 14 Oct 2018 14:04:31 +0000 (16:04 +0200)
The Module.symvers with the exported symbols of all other kernel modules in
OpenWrt is usually placed in the main source directory of the package. But
the actual sources for batman-adv are found in net/batman-adv. OpenWrt must
therefore be informed to move it to this subdirectory or otherwise modpost
will fail to find the symbols

  WARNING: "cfg80211_get_station" [.../batman-adv-2018.1/net/batman-adv/batman-adv.ko] undefined!

The dependency will then be missing in the .modinfo depends= option and
thus it the kernel module loader will not correctly load the cfg80211.ko
during bootup.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile

index 1f68cdce522bfda00a8dacbebcf38171a0337867..e261015255a6d45db3b7cfe6c82e2603705328f3 100644 (file)
@@ -16,6 +16,7 @@ PKG_HASH:=b866b28dbbe5c9238abbdf5abbc30fc526dea56898ce4c1bd76d5c017843048b
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
 PKG_LICENSE:=GPL-2.0
+PKG_EXTMOD_SUBDIRS=net/batman-adv
 
 STAMP_CONFIGURED_DEPENDS := $(STAGING_DIR)/usr/include/mac80211-backport/backport/autoconf.h