alfred: improve version string 529/head
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 11 Nov 2019 11:40:35 +0000 (12:40 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 11 Nov 2019 11:40:35 +0000 (12:40 +0100)
This changes the package version string so it does not start
with "openwrt", but with the base version we are modifying:

So far: openwrt-2019.4-1
Now:    2019.4-openwrt-1

Since it's us modifying version 2019.4 (in this case), this order
is more convenient (and also closer to what the kernel version
string does).

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
alfred/Makefile

index 0786b2b4ed958c689db4abde8639ee184b6389c1..f4e3e64dec91ddfc659a2e7414d078d09e0f57ec 100644 (file)
@@ -59,7 +59,7 @@ MAKE_FLAGS += \
        CONFIG_ALFRED_CAPABILITIES=n \
         LIBNL_NAME="libnl-tiny" \
         LIBNL_GENL_NAME="libnl-tiny" \
        CONFIG_ALFRED_CAPABILITIES=n \
         LIBNL_NAME="libnl-tiny" \
         LIBNL_GENL_NAME="libnl-tiny" \
-        REVISION="openwrt-$(PKG_VERSION)-$(PKG_RELEASE)"
+        REVISION="$(PKG_VERSION)-openwrt-$(PKG_RELEASE)"
 
 TARGET_CFLAGS  += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections -fuse-linker-plugin
 
 TARGET_CFLAGS  += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections -fuse-linker-plugin