bird: fix build dependencies
authorJo-Philipp Wich <jo@mein.io>
Tue, 16 Jan 2018 15:30:36 +0000 (16:30 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 16 Jan 2018 15:34:51 +0000 (16:34 +0100)
The PKG_BUILD_DEPENDS variable must refer to source packages instead of
binary package names.

Fixes the following errors on current OpenWrt master:

Upon scripts/feeds install:

    WARNING: No feed for source package 'libncurses' found
    WARNING: No feed for source package 'libreadline' found

Upon metadata scanning and dependency resolution:

    WARNING: Makefile 'package/feeds/routing/bird/Makefile' has a build dependency on 'libncurses', which does not exist
    WARNING: Makefile 'package/feeds/routing/bird/Makefile' has a build dependency on 'libreadline', which does not exist

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
bird/Makefile

index f691add6d0e1e7b82309b541813ca36071bb1821..b44114e9284f5b23c908c2a147c5959df8326f1a 100644 (file)
@@ -13,7 +13,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
 PKG_MD5SUM:=39c51cf57c3ba8b5978b2a657ffa2f647ec7f3ae643e91cf42ee5cb070cf7e7c
-PKG_BUILD_DEPENDS:=libncurses libreadline
+PKG_BUILD_DEPENDS:=ncurses readline
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 
 PKG_LICENSE:=GPL-2.0