Allow HTTP Plugin
authorHenning Rogge <hrogge@gmail.com>
Wed, 7 Jun 2017 19:49:05 +0000 (21:49 +0200)
committerHenning Rogge <hrogge@gmail.com>
Wed, 7 Jun 2017 19:49:05 +0000 (21:49 +0200)
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile

index 8af701c345072ad6f650a061a4202acec4d3f91b..1cc037aff3ebc9a2a1ea2d2c94857d62b8b28006 100644 (file)
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
+       config OONF_GENERIC_HTTP
+               bool "http plugin enabled"
+               help
+                       The HTTP plugin allows HTTP access to all telnet commands.
+               default n
+
        config OONF_OLSRV2_MPR
                bool "MPR plugin enabled"
                help
        config OONF_OLSRV2_MPR
                bool "MPR plugin enabled"
                help
index d77c530b25e5db98b1083c28065092579a380cf5..aee62242b8c2b84ad581451eaf8150fe40331f75 100644 (file)
@@ -25,6 +25,7 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
+        $(if $(filter y,$(OONF_GENERIC_HTTP)),http,) \
     ))
 
 CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
     ))
 
 CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \