miniupnpd: fix typo in init script
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 1 Jul 2014 10:09:06 +0000 (12:09 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 1 Jul 2014 10:12:42 +0000 (12:12 +0200)
A missing space in the init script prevented the detection of the external
interface. Fixes OpenWrt bug #16910.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
miniupnpd/Makefile
miniupnpd/files/miniupnpd.init

index b6d23036364ddb9bbbb2fd110f5d4e419ee94bab..83e7f840a35e230bc71bd5d17407a450f8a00365 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.8.20140523
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 68ec2118c06e6d5304eb5017a96e5197aabd2c9c..f8a66fd6586e15b3b550ff3a18c8eb13d19c89f8 100644 (file)
@@ -105,7 +105,7 @@ start() {
             [ -n "$extiface" ] || network_find_wan6 extiface
         fi
 
-       [ -n "$ifname"] || network_get_device ifname ${extiface}
+       [ -n "$ifname" ] || network_get_device ifname ${extiface}
 
        if [ -n "$conffile" ]; then
                args="-f $conffile"