cjdns: fix build on mac osx
authorCaleb James DeLisle <cjd@cjdns.fr>
Tue, 23 Jun 2015 05:50:57 +0000 (07:50 +0200)
committerLars Gierth <larsg@systemli.org>
Tue, 23 Jun 2015 12:43:07 +0000 (14:43 +0200)
Signed-off-by: Lars Gierth <larsg@systemli.org>
Conflicts:
cjdns/Makefile

cjdns/Makefile

index 835af220146a1062b73225175d99ea1192059a50..36772cd0c423524b0dc1a234af98a6baa48aebc3 100644 (file)
@@ -79,11 +79,14 @@ endif
 define Build/Compile
        CROSS="true" \
        CC="$(TARGET_CC)" \
+       AR="$(TARGET_AR)" \
+       RANLIB="$(TARGET_RANLIB)" \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        SYSTEM="linux" \
        TARGET_ARCH="$(CONFIG_ARCH)" \
        SSP_SUPPORT="$(CONFIG_SSP_SUPPORT)" \
+       GYP_ADDITIONAL_ARGS="-f make-linux" \
        $(PKG_DO_VARS) \
        $(PKG_BUILD_DIR)/do
 endef