bird2: fix compilation with GCC 10 593/head
authorRosen Penev <rosenp@gmail.com>
Tue, 11 Aug 2020 19:26:42 +0000 (12:26 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 11 Aug 2020 19:36:34 +0000 (12:36 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
bird2/Makefile
bird2/patches/010-gcc10.patch [new file with mode: 0644]

index fc3d1c27d2a02d01b0100de04074980730ee1486..6962eedbbb80b0d03d0971aad8f7cb0af48521b9 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird2
 PKG_VERSION:=2.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
diff --git a/bird2/patches/010-gcc10.patch b/bird2/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..172646b
--- /dev/null
@@ -0,0 +1,30 @@
+From 4bbc10614f3431c37e6352f5a6ea5c693c31021e Mon Sep 17 00:00:00 2001
+From: Maria Matejka <mq@ucw.cz>
+Date: Tue, 4 Feb 2020 10:11:16 +0100
+Subject: [PATCH] Added missing extern
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Thanks to Robert Scheck <bird@robert-scheck.de> who reported it
+and Toke Høiland-Jørgensen <toke@toke.dk> who suggested this patch.
+---
+ nest/route.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nest/route.h b/nest/route.h
+index d2a07f09..b927db5f 100644
+--- a/nest/route.h
++++ b/nest/route.h
+@@ -458,7 +458,7 @@ typedef struct rta {
+                                          protocol-specific metric is availabe */
+-const char * rta_dest_names[RTD_MAX];
++extern const char * rta_dest_names[RTD_MAX];
+ static inline const char *rta_dest_name(uint n)
+ { return (n < RTD_MAX) ? rta_dest_names[n] : "???"; }
+-- 
+2.26.2
+