bird: explicitly set C standard 133/head
authorDirk Neukirchen <dirkneukirchen@web.de>
Mon, 15 Jun 2015 10:36:55 +0000 (12:36 +0200)
committerDirk Neukirchen <dirkneukirchen@web.de>
Wed, 19 Aug 2015 08:45:05 +0000 (10:45 +0200)
fixes gcc5 compile

compile error was:
cf-lex.o: In function `add_tail':
cf-lex.c:(.text+0x2d1): multiple definition of `add_tail'
cf-parse.tab.o:cf-parse.tab.c:(.text+0x1f9): first defined here

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
bird/Makefile

index 5f8200c8a94fdbfca81e9bd1fadbc73cf9faef57..eeb5106aceb490f7e4d9cba88be4884925ad1c52 100644 (file)
@@ -161,6 +161,8 @@ endef
 
 CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)"
 
+TARGET_CFLAGS+=-std=gnu89
+
 define Build/Template
 
 $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)