babeld: Update to version 1.8.3 + fix init 415/head
authorMichael Adams <unquietwiki@gmail.com>
Thu, 27 Sep 2018 02:14:45 +0000 (19:14 -0700)
committerMichael Adams <unquietwiki@gmail.com>
Wed, 3 Oct 2018 17:04:46 +0000 (10:04 -0700)
24 September 2018: babeld-1.8.3

  * Fixed a read-only two byte buffer overflow in the packet parser.
    This is a read-only overflow, and hence most probably not exploitable.
  * Fixed an issue with creating unreachable routes on recent kernels
    (4.16 and up).  Thanks to Christof Schulze.
  * Notice interface changes faster by listening to more netlink events.
    Thanks to Christof Schulze.
  * Fixed a local interface issue when an interface has no link-local
    address.  Thanks to Christof Schulze.

Also, the init script was edited to kill babeld on stop; restart works properly now, as well.

Signed-off-by: Michael Adams <unquietwiki@gmail.com>
babeld/Makefile
babeld/files/babeld.init

index f4c65c9bc2a59452a57d3f589bb726a5ea9a78de..075c2c00f44aefe828c274e5e376f8b7586f3d74 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.8.2
+PKG_VERSION:=1.8.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
-PKG_HASH:=07edecb132386d5561a767482bc5200e04239b18e48c2f0f47ae1c78d60fe5dc
+PKG_HASH:=368cc56812e07bbb64d0b609b6f411292e46b15610fe947501d4b310377366bd
 PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
index 378a8abcdb7e5e337d1e1e26ea3ad3fe9eb80cf5..7b25ef48c6b0a5cea6861824b5221ea1e11f64f2 100755 (executable)
@@ -197,6 +197,10 @@ start_service() {
        procd_close_instance
 }
 
+stop_service() {
+       killall -9 babeld
+}
+
 service_triggers() {
        procd_add_reload_trigger babeld
 }