asterisk-15.x: bump to 15.2.0 240/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 14 Jan 2018 18:18:05 +0000 (19:18 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 14 Jan 2018 18:18:12 +0000 (19:18 +0100)
- Remove 003-disable-ast-xml-docs.patch, it doesn't apply anymore.
  Instead change --enable-xmldoc into --disable-xmldoc in the Makefile.
- Refresh patches.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/asterisk-15.x/Makefile
net/asterisk-15.x/patches/001-disable-semaphores-check.patch
net/asterisk-15.x/patches/002-undef-res-ninit.patch
net/asterisk-15.x/patches/003-disable-ast-xml-docs.patch [deleted file]
net/asterisk-15.x/patches/004-disable-check-for-hrirs.patch
net/asterisk-15.x/patches/100-build-reproducibly.patch

index 4540276fd63197828dbe37577c55e1d633a5b1b1..e5e7183aeb014b7a8776ddfba8c965e984d0c41e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk15
-PKG_VERSION:=15.1.4
+PKG_VERSION:=15.2.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/asterisk/releases
-PKG_HASH:=8ce3ffbff473410ae0ed0472adea22b01a20f9ec784ebfec51393282028acc16
+PKG_HASH:=5ab2c80e3cb1a933013415d49dbb100e5d2045aeaf926f8eb0ed3b77460a6d83
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libxml2/host
@@ -240,6 +240,7 @@ endif
 TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS+= \
+       --disable-xmldoc \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-chan-alsa),--with-asound="$(STAGING_DIR)/usr",--without-asound) \
        --without-execinfo \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-chan-mobile),--with-bluetooth="$(STAGING_DIR)/usr",--without-bluetooth) \
@@ -277,8 +278,7 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-format-ogg-vorbis),--with-vorbis="$(STAGING_DIR)/usr",--without-vorbis) \
        --without-vpb \
        --with-z="$(STAGING_DIR)/usr" \
-       --with-sounds-cache="$(DL_DIR)" \
-       --enable-xmldoc
+       --with-sounds-cache="$(DL_DIR)"
 
 ifeq ($(CONFIG_PACKAGE_$(PKG_NAME)-codec-speex)$(CONFIG_PACKAGE_$(PKG_NAME)-format-ogg-speex)$(CONFIG_PACKAGE_$(PKG_NAME)-func-speex),)
 CONFIGURE_ARGS+= \
index e73f48e7869ec941f159ce17b20760ee441afa9f..5bbe7c97c59936e684cdfb3d65ec68d66dcff8a2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -990,19 +990,6 @@ AC_LINK_IFELSE(
+@@ -992,19 +992,6 @@ AC_LINK_IFELSE(
    ]
  )
  
index c999803711305d2a5f1930144d02577893920156..963b97773e389d1e21810dd08c3a394121cb1905 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1317,7 +1317,6 @@ AC_LINK_IFELSE(
+@@ -1326,7 +1326,6 @@ AC_LINK_IFELSE(
                        #include <resolv.h>],
                        [int foo = res_ninit(NULL);])],
        AC_MSG_RESULT(yes)
diff --git a/net/asterisk-15.x/patches/003-disable-ast-xml-docs.patch b/net/asterisk-15.x/patches/003-disable-ast-xml-docs.patch
deleted file mode 100644 (file)
index 12b3f73..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/include/asterisk/xml.h
-+++ b/include/asterisk/xml.h
-@@ -246,10 +246,5 @@ struct ast_xml_node *ast_xml_xpath_get_f
-  */
- struct ast_xml_xpath_results *ast_xml_query(struct ast_xml_doc *doc, const char *xpath_str);
--/* Features using ast_xml_ */
--#ifdef HAVE_LIBXML2
--#define AST_XML_DOCS
--#endif
--
- #endif /* _ASTERISK_XML_H */
index 5e3f6f6ecb3d5583bdd2bfe26545b5b796ae378b..cd6d6aa4f2e6714655631d21a7412ec34a81263d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2722,7 +2722,7 @@ else
+@@ -2739,7 +2739,7 @@ else
  fi
  
  # conf_bridge (binaural rendering): check if HRIRs are available
index 9f076664048725dd24ea81d6837f491ace231ef1..e68d191cf251dc29696c32c6dfbf657bad6da4d0 100644 (file)
@@ -17,7 +17,7 @@
   * build.h
 --- a/Makefile
 +++ b/Makefile
-@@ -464,7 +464,7 @@ doc/core-en_US.xml: makeopts .lastclean
+@@ -476,7 +476,7 @@ doc/core-en_US.xml: makeopts .lastclean
        @echo "<docs xmlns:xi=\"http://www.w3.org/2001/XInclude\">" >> $@
        @for x in $(MOD_SUBDIRS); do \
                printf "$$x " ; \