asterisk-chan-dongle: add patch to force OpenWrt CFLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Fri, 9 Mar 2018 13:49:18 +0000 (14:49 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Fri, 9 Mar 2018 13:49:20 +0000 (14:49 +0100)
Prevent ./configure from adding '-O6' to CFLAGS.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/asterisk-chan-dongle/patches/300-use-openwrt-flags.patch [new file with mode: 0644]

diff --git a/net/asterisk-chan-dongle/patches/300-use-openwrt-flags.patch b/net/asterisk-chan-dongle/patches/300-use-openwrt-flags.patch
new file mode 100644 (file)
index 0000000..1380e70
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -216,8 +216,6 @@ dnl Apply options to defines
+ if test "x$enable_debug" = "xyes" ; then
+   CFLAGS="$CFLAGS -O0 -g"
+   AC_DEFINE([__DEBUG__], [1], [Build with debugging])
+-else
+-  CFLAGS="$CFLAGS -O6"
+ fi
+ dnl Asterisk header files use lots of old style declarations, ignore those.