kamailio-4.x: build against libevent2
authorDaniel Golle <daniel@makrotopia.org>
Fri, 26 Jun 2015 13:06:56 +0000 (15:06 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 8 Oct 2015 13:18:32 +0000 (15:18 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/kamailio-4.x/Makefile
net/kamailio-4.x/patches/120-libevent-libs.patch

index 1365fed8abaa97b993b8baeb431ecdf16d20fea0..f02ec01506cf4f6714a2dc686fa43e1fa6e1e540 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kamailio4
 PKG_VERSION:=4.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src/
 PKG_SOURCE:=kamailio-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
@@ -125,7 +125,7 @@ $(eval $(call BuildKamailio4Module,benchmark,Config benchmark,,))
 $(eval $(call BuildKamailio4Module,cfgutils,Config utilities,,))
 $(eval $(call BuildKamailio4Module,cfg_db,Load core and module parameters from database,,+kamailio4-mod-db-sqlite))
 $(eval $(call BuildKamailio4Module,cfg_rpc,Update core and module parameters at runtime via RPC interface,,))
-$(eval $(call BuildKamailio4Module,cnxcc,Limit call duration,,+kamailio4-mod-dialog +libhiredis +libevent))
+$(eval $(call BuildKamailio4Module,cnxcc,Limit call duration,,+kamailio4-mod-dialog +libhiredis +libevent2))
 $(eval $(call BuildKamailio4Module,corex,Legacy functions,,))
 $(eval $(call BuildKamailio4Module,ctl,BINRPC transport interface,,))
 $(eval $(call BuildKamailio4Module,db_flatstore,Fast writing-only text database-backed,,))
@@ -152,9 +152,9 @@ $(eval $(call BuildKamailio4Module,htable,Hash Table,,))
 $(eval $(call BuildKamailio4Module,imc,IM conferencing,,+kamailio4-mod-db-mysql +kamailio4-mod-tm))
 $(eval $(call BuildKamailio4Module,ipops,IP and IPv6 operations,,))
 $(eval $(call BuildKamailio4Module,jansson,Alternative access to JSON document attributes,,+jansson))
-$(eval $(call BuildKamailio4Module,janssonrpc-c,Alternative JSONRPC server,,+kamailio4-mod-jansson +libevent2))
+$(eval $(call BuildKamailio4Module,janssonrpc-c,Alternative JSONRPC server,,+kamailio4-mod-jansson +libevent2))
 $(eval $(call BuildKamailio4Module,json,Access to JSON document attributes,,+libjson-c))
-$(eval $(call BuildKamailio4Module,jsonrpc-s,JSONRPC server over HTTP,,+kamailio4-mod-json +libevent))
+$(eval $(call BuildKamailio4Module,jsonrpc-s,JSONRPC server over HTTP,,+kamailio4-mod-json +libevent2))
 $(eval $(call BuildKamailio4Module,kex,Core extensions,,))
 $(eval $(call BuildKamailio4Module,lcr,Least Cost Routing,,+kamailio4-mod-tm +libpcre))
 $(eval $(call BuildKamailio4Module,ldap,LDAP connector,,+libopenldap))
@@ -242,7 +242,7 @@ PKG_MAKE_ARGS:= \
        CC="$(TARGET_CC)" \
        ARCH="$(ARCH)"  \
        DESTDIR=$(PKG_INSTALL_DIR) \
-       EXTRA_LIBS="-L$(STAGING_DIR)/usr/lib/ -L$(STAGING_DIR)/usr/lib/libevent" \
+       EXTRA_LIBS="-L$(STAGING_DIR)/usr/lib/" \
        quiet=verbose
 
 define Build/Compile
index f4d65697839d72941cd9d400b117779693ede5fd..918d27ba16f409fce06d1d92958cf033c75a7f6f 100644 (file)
@@ -11,3 +11,15 @@ Index: kamailio4-4.3.0/modules/cnxcc/Makefile
  DEFS+=-DOPENSER_MOD_INTERFACE
  SERLIBPATH=../../lib
  SER_LIBS+=$(SERLIBPATH)/kmi/kmi
+Index: kamailio4-4.3.0/modules/janssonrpc-c/netstring.h
+===================================================================
+--- kamailio4-4.3.0.orig/modules/janssonrpc-c/netstring.h
++++ kamailio4-4.3.0/modules/janssonrpc-c/netstring.h
+@@ -24,6 +24,7 @@
+ #define __NETSTRING_STREAM_H
+ #include <string.h>
++#include <event2/buffer.h>
+ #include <event2/bufferevent.h>
+ typedef struct {