libsrtp: update to 1.5.4
authorJiri Slachta <jiri@slachta.eu>
Mon, 8 May 2017 15:23:03 +0000 (17:23 +0200)
committerJiri Slachta <jiri@slachta.eu>
Mon, 8 May 2017 15:23:03 +0000 (17:23 +0200)
Signed-off-by: Jiri Slachta <jiri@slachta.eu>
libs/libsrtp/Makefile
libs/libsrtp/patches/1003_fix_mips_namespace_collision.patch
libs/libsrtp/patches/1005_fix_data_alignment.patch
libs/libsrtp/patches/1008_shared-lib.patch

index eb7d3bcbcd41e813c2e3e85777f04f3e2b63113f..3c6f3dc84e37a960a698af4936a7f2f84d10485e 100644 (file)
@@ -1,6 +1,7 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2006-2017 OpenWrt.org
 # Copyright (C) 2011 Victor Seva <linuxmaniac@torreviejawireless.org>
+# Copyright (C) 2017 Jiri Slachta <jiri@slachta.eu>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsrtp
-PKG_VERSION:=1.4.4
+PKG_VERSION:=1.5.4
 PKG_RELEASE:=1
 
-PKG_SOURCE:=srtp-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=@SF/srtp
-PKG_MD5SUM:=9b449edb011c934ca97009e7e0566d22
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/cisco/libsrtp.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=078c4a5b2a4380dea025998ceea9e0a1e3164d2d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/srtp
-PKG_INSTALL:=1
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -25,20 +27,23 @@ PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
 include $(INCLUDE_DIR)/package.mk
 
 TARGET_CFLAGS += $(FPIC)
-CONFIGURE_ARGS += --disable-stdout --enable-syslog
+CONFIGURE_ARGS += \
+       --disable-stdout \
+       --enable-syslog
 
 define Package/libsrtp
   SUBMENU:=Telephony
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Secure Real-time Transport Protocol (SRTP) library
+  DEPENDS:=+libpcap
   URL:=http://sourceforge.net/projects/srtp
 endef
 
 define Package/libsrtp/description
-Open-source implementation of the Secure Real-time Transport
-Protocol (SRTP) originally authored by Cisco Systems, Inc.
-It is available under a BSD-style license.
+ Open-source implementation of the Secure Real-time Transport
+ Protocol (SRTP) originally authored by Cisco Systems, Inc.
+ It is available under a BSD-style license.
 endef
 
 define Build/Install
@@ -51,12 +56,15 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/srtp $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsrtp.pc $(1)/usr/lib/pkgconfig/
 endef
 
 
 define Package/libsrtp/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so.* \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so.* \
                $(1)/usr/lib/
 endef
 
index 534ea4bc30e8e3c83881bfe903c4008e2000aa25..b4e2d570c9682f378f4694c7b2103f950897fa0d 100644 (file)
@@ -1,11 +1,6 @@
-Description: Fix MIPS namespace collision
-Author: Thiemo Seufer <ths@networkno.de>
-Origin: vendor, http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=24;bug=439976
-Bug-Debian: http://bugs.debian.org/439976
-Last-Update: 2010-02-28
 --- a/test/srtp_driver.c
 +++ b/test/srtp_driver.c
-@@ -314,7 +314,7 @@ main (int argc, char *argv[]) {
+@@ -341,7 +341,7 @@ main (int argc, char *argv[]) {
    if (do_codec_timing) {
      srtp_policy_t policy;
      int ignore;
@@ -14,8 +9,8 @@ Last-Update: 2010-02-28
  
      crypto_policy_set_rtp_default(&policy.rtp);
      crypto_policy_set_rtcp_default(&policy.rtcp);
-@@ -323,33 +323,33 @@ main (int argc, char *argv[]) {
-     policy.key  = test_key;
+@@ -353,33 +353,33 @@ main (int argc, char *argv[]) {
+     policy.allow_repeat_tx = 0;
      policy.next = NULL;
  
 -    printf("mips estimate: %e\n", mips);
index 4cb888983c9ec8d3cddeef7ceb46de917c9bc264..5f2a2e0c24e85608a3d2cc2a0ce0b4ed32b7fd2c 100644 (file)
@@ -1,20 +1,14 @@
-Description: Fix data alignment
-Author: "Martin Guy" <martinwguy@yahoo.it>
-Origin: vendor, http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;bug=470505
-Bug: http://sourceforge.net/tracker/index.php?func=detail&aid=1912057&group_id=38894&atid=423799
-Bug-Debian: http://bugs.debian.org/470505
-Last-Update: 2011-05-30
 --- a/test/srtp_driver.c
 +++ b/test/srtp_driver.c
-@@ -1129,7 +1129,6 @@ mips_estimate(int num_trials, int *ignor
+@@ -1198,7 +1198,6 @@ mips_estimate(int num_trials, int *ignor
   * These packets were made with the default SRTP policy.
   */
  
 -
  err_status_t
  srtp_validate() {
-   unsigned char test_key[30] = {
-@@ -1144,14 +1143,14 @@ srtp_validate() {
+   uint8_t srtp_plaintext_ref[28] = {
+@@ -1207,14 +1206,14 @@ srtp_validate() {
      0xab, 0xab, 0xab, 0xab, 0xab, 0xab, 0xab, 0xab, 
      0xab, 0xab, 0xab, 0xab
    };
index 96a13ca6ab5063465dba3422f6a3c53ffdb7d04d..e29305c0df432782110ac67dd23fae186076300f 100644 (file)
@@ -1,55 +1,11 @@
-Description: Hack build routines to compile shared library
-Author: loki_val and solar
-Origin: http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-libs/libsrtp/files/libsrtp-1.4.4-shared.patch
-Last-Update: 2010-03-19
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -15,7 +15,7 @@
+@@ -20,7 +20,7 @@ HAVE_PKG_CONFIG = @HAVE_PKG_CONFIG@
  
- .PHONY: all test build_table_apps
+ .PHONY: all shared_library test build_table_apps
  
 -all: test 
-+all: libsrtp.so test
++all: shared_library test
  
  runtest: build_table_apps test
        @echo "running libsrtp test applications..."
-@@ -67,7 +67,7 @@ libdir = @libdir@
- # implicit rules for object files and test apps
- %.o: %.c
--      $(COMPILE) -c $< -o $@
-+      $(COMPILE) -fPIC -c $< -o $@
- %$(EXE): %.c
-       $(COMPILE) $(LDFLAGS) $< -o $@ $(SRTPLIB) $(LIBS)
-@@ -105,6 +105,9 @@ libsrtp.a: $(srtpobj) $(cryptobj) $(gdoi
-       ar cr libsrtp.a $^
-       $(RANLIB) libsrtp.a
-+libsrtp.so: $(srtpobj) $(cryptobj) $(gdoi)
-+      $(CC) $(LDFLAGS) -shared -Wl,-soname,libsrtp.so.0 -o libsrtp.so.0.0  $^
-+
- # libcryptomath.a contains general-purpose routines that are used to
- # generate tables and verify cryptoalgorithm implementations - this
- # library is not meant to be included in production code
-@@ -197,6 +200,11 @@ install:
-       cp include/*.h $(DESTDIR)$(includedir)/srtp  
-       cp crypto/include/*.h $(DESTDIR)$(includedir)/srtp
-       if [ -f libsrtp.a ]; then cp libsrtp.a $(DESTDIR)$(libdir)/; fi
-+      if [ -f libsrtp.so.0.0 ]; then \
-+              cp libsrtp.so.0.0 $(DESTDIR)$(libdir)/; \
-+              ln -s libsrtp.so.0.0 $(DESTDIR)$(libdir)/libsrtp.so.0; \
-+              ln -s libsrtp.so.0.0 $(DESTDIR)$(libdir)/libsrtp.so; \
-+      fi
- uninstall:
-       rm -rf $(DESTDIR)$(includedir)/srtp
-@@ -204,7 +212,7 @@ uninstall:
- clean:
-       rm -rf $(cryptobj) $(srtpobj) $(cryptomath) TAGS \
--        libcryptomath.a libsrtp.a core *.core test/core
-+        libcryptomath.a libsrtp.a libsrtp.so.0.0 core *.core test/core
-       for a in * */* */*/*; do                        \
-               if [ -f "$$a~" ] ; then rm -f $$a~; fi; \
-         done;