fix multiport netfilter module installation (patch from #1280)
[openwrt/openwrt.git] / Makefile
index a3d5720db3b2b0eb7df3e8658c4c77e801da6d70..35fc2c8884e036ae93e656f9c538ae90acc614c9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -82,10 +82,10 @@ tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -187,9 +187,6 @@ doc:
 docclean:
        $(MAKE) -C docs/ clean
 
 docclean:
        $(MAKE) -C docs/ clean
 
-symlinks:
-       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
-
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help