hostapd: ensure that wpa_supplicant_setup_vif() returns success in cases where wpa_su...
[openwrt/openwrt.git] / Makefile
index 31042b2e09cf267ba65d24e44acd641ea821ea81..57575eac54948affe31727d12736e5cf0d15389c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -40,15 +40,12 @@ else
 
 $(toolchain/stamp-install): $(tools/stamp-install)
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-cleanup): $(target/stamp-compile)
-$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-compile): $(target/stamp-compile)
 $(package/stamp-install): $(package/stamp-compile)
-$(package/stamp-rootfs-prepare): $(package/stamp-install)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
 
-$(BUILD_DIR)/.prepared: Makefile
-       @mkdir -p $$(dirname $@)
-       @touch $@
+printdb:
+       @true
 
 prepare: $(target/stamp-compile)
 
@@ -60,6 +57,11 @@ dirclean: clean
        rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
 
+ifndef DUMP_TARGET_DB
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
 tmp/.prereq_packages: .config
        unset ERROR; \
        for package in $(sort $(prereq-y) $(prereq-m)); do \
@@ -70,12 +72,19 @@ tmp/.prereq_packages: .config
                false; \
        fi
        touch $@
+endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
+       @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+               echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+               echo '       The missing file will cause configure scripts to fail during compilation.'; \
+               echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+               exit 1; \
+       fi
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
-world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
 
 # update all feeds, re-create index files, install symlinks