fix syslogd output to /dev/console (patch from #1170)
[openwrt/openwrt.git] / Makefile
index daadbeacf65a7bb4ecd22f745ef4a3d828dfcbaf..84c8c51156e7689947287fc0bbe6ea9d599db3ae 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -82,10 +82,10 @@ tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -181,8 +181,14 @@ distclean: dirclean config-clean
 help:
        cat README
 
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 symlinks:
-       scripts/feeds.sh https://svn.openwrt.org/openwrt/packages
+       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;