disable dma offset for now
[openwrt/openwrt.git] / Makefile
index a3d5720db3b2b0eb7df3e8658c4c77e801da6d70..fea8ed316230cd1d44bc4c278d9a6476e0587a23 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -82,10 +82,10 @@ tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -113,6 +113,10 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
 menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
+
 package/%: tmp/.pkginfo tmp/.targetinfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
@@ -187,9 +191,6 @@ doc:
 docclean:
        $(MAKE) -C docs/ clean
 
-symlinks:
-       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
-
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help