autotools.mk: add a (dummy) libintl build dependency to any package using the libtool...
[openwrt/openwrt.git] / include / autotools.mk
index 5e1c1053e487a78e7fcb0b459d041773ac759d26..592fcdebd732d4dc460d14ef19d72c7762369dff 100644 (file)
@@ -61,14 +61,14 @@ define autoreconf_target
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif