ubox: turn logd into a separate package
[openwrt/openwrt.git] / include / autotools.mk
index 8796598569a748c4d61ec20d9476247929f562ed..c6aa47e0bef311697b4def7a7183d1ac59dcf599 100644 (file)
@@ -83,6 +83,23 @@ define patch_libtool_target
     $(PKG_BUILD_DIR)))
 endef
 
+define gettext_version_target
+       (cd $(PKG_BUILD_DIR) && \
+               GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.*\([0-9]\.[0-9]\{2\}\.[0-9]\).*/\1/p' ) && \
+               $(STAGING_DIR_HOST)/bin/sed \
+                       -i $(PKG_BUILD_DIR)/configure.ac \
+                       -e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+               $(STAGING_DIR_HOSTPKG)/bin/autopoint --force \
+       );
+endef
+
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += gettext_version_target
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf_target
+ endif
+endif
+
 ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += patch_libtool_target
 endif