generic: ar8216: simplify and rename ar8327_config_port
[openwrt/openwrt.git] / include / cmake.mk
index 4701020f91863cccb4a5b7e5c6a51b1cbf5d377f..64a0654f9685004de625b22279ac58596105cc1b 100644 (file)
@@ -1,6 +1,10 @@
 PKG_INSTALL:=1
 
-MAKE_FLAGS+=VERBOSE=1
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+  MAKE_FLAGS+=VERBOSE=1
+endif
+
+CMAKE_SOURCE_DIR:=.
 
 ifeq ($(CONFIG_CCACHE),)
  ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
@@ -51,8 +55,9 @@ define Build/Configure/Default
                        -DCMAKE_STRIP=: \
                        -DCMAKE_INSTALL_PREFIX=/usr \
                        -DDL_LIBRARY=$(STAGING_DIR) \
+                        -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
                        $(CMAKE_OPTIONS) \
-               . \
+               $(CMAKE_SOURCE_DIR) \
        )
 endef