ar71xx: add support for the Allnet ALL0315N board
[openwrt/openwrt.git] / include / download.mk
index 7009bfcd44c58d18fb8b92fdbe72aea84fbce515..823ddf93f882c426cc9b9a36b3fe02be82f49a84 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -45,7 +45,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
+       $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
 endef
 
 define DownloadMethod/cvs
@@ -87,7 +87,7 @@ define DownloadMethod/git
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               git clone $(URL) $(SUBDIR) && \
+               git clone $(URL) $(SUBDIR) --recursive && \
                (cd $(SUBDIR) && git checkout $(VERSION)) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \