use gcc 4.3.5 for avr32
[openwrt/openwrt.git] / include / host-build.mk
index 1b7f354066ece81a3aa0f131bd61baba3d24c33b..6f742d28a1a2287e2e8e337619c997a9f0af5a2b 100644 (file)
@@ -153,12 +153,12 @@ ifndef DUMP
                $(call Host/Compile)
                touch $$@
 
-    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
                $(call Host/Install)
                mkdir -p $$(shell dirname $$@)
                touch $$@
   else
-    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
                $(call Host/Compile)
                $(call Host/Install)
                touch $$@