build: call Host/Uninstall before wiping the host build dir
[openwrt/openwrt.git] / include / host-build.mk
index 827ea6bbfb1be72e38309de3fe48435e3aa8172f..9fc14241c64b69bd3a3a4ad39ca1c301b01139a4 100644 (file)
@@ -190,11 +190,11 @@ ifndef DUMP
   host-install: host-compile
 
   host-clean-build: FORCE
+       $(call Host/Uninstall)
        rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
 
   host-clean: host-clean-build
        $(call Host/Clean)
-       $(call Host/Uninstall)
        rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)