ar71xx: add support for RB mAP L-2nD
[openwrt/openwrt.git] / include / host-build.mk
index 6a335fcbc3b1fe62e4b18f7e2f7f1b590e8b1c1c..ffb68468f9972a379cee39503d27433ddf2dc02a 100644 (file)
@@ -108,7 +108,7 @@ define Host/Compile
 endef
 
 define Host/Install/Default
-       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
 endef
 
 define Host/Install
@@ -176,15 +176,21 @@ ifndef DUMP
       $(t): host-$(t)
       .$(t): .host-$(t)
     )
+    clean-build: host-clean-build
   endif
 
   $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
   $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
   $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
-  host-clean: FORCE
+  host-install: host-compile
+
+  host-clean-build: FORCE
+       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
+
+  host-clean: host-clean-build
        $(call Host/Clean)
        $(call Host/Uninstall)
-       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+       rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)
       host-compile: