build: move the XARGS variable out of the host checks, since a working xargs is built...
[openwrt/openwrt.git] / include / host.mk
index b44c1bf1ac6f3a9a1af9f865e48613a0d87d5ec4..000fb1898475270eb533d833e5012ecdfd3e50bd 100644 (file)
@@ -54,11 +54,6 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
                fi; \
-               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
-                       echo 'XARGS:=xargs -r' >> $@; \
-               else \
-                       echo 'XARGS:=xargs' >> $@; \
-               fi; \
                PATCH=`which gpatch 2>/dev/null`; \
                [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
                echo "PATCH:=$$PATCH" >> $@; \