switch from ext2 to ext4 (w/o) journaling
[openwrt/openwrt.git] / include / host.mk
index 8092e8db77ac74e1f07c2c1ab1e15b7f1a9a30b4..9b8a32b672d3579c5cbe1deed2f7625dec912e0a 100644 (file)
@@ -36,7 +36,7 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
                        GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
@@ -59,6 +59,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo 'XARGS:=xargs' >> $@; \
                fi; \
+               PATCH=`which gpatch 2>/dev/null`; \
+               [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
+               echo "PATCH:=$$PATCH" >> $@; \
        )
 
 endif