switch from ext2 to ext4 (w/o) journaling
[openwrt/openwrt.git] / include / host.mk
index b93ab8d536d2f0df3e973ea271b1c090dca04264..9b8a32b672d3579c5cbe1deed2f7625dec912e0a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,17 @@ export TAR FIND
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
+
+try-run = $(shell set -e; \
+       TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
+       if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
+       rm -f "$$TMP_F"; \
+)
+
+host-cc-option = $(call try-run, \
+       $(HOSTCC) $(HOST_CFLAGS) $(1) -c -xc /dev/null -o "$$TMP_F",$(1),$(2) \
+)
+
 .PRECIOUS: $(TMP_DIR)/.host.mk
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
@@ -21,11 +32,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
                        Linux) HOST_ARCH=`uname -m`;; \
+                       Darwin) HOST_ARCH=`uname -m`;; \
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -n "$$GNU_HOST_NAME" ] || \
-                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
+                       GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
@@ -47,6 +59,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo 'XARGS:=xargs' >> $@; \
                fi; \
+               PATCH=`which gpatch 2>/dev/null`; \
+               [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
+               echo "PATCH:=$$PATCH" >> $@; \
        )
 
 endif