build: move lzma2eva build step to image-commands.mk
[openwrt/openwrt.git] / include / image-commands.mk
index c513f19d3a1244ae2d6cd692b0f2545b393bda1c..093b93d0e96b0729babb7c117adb701c36966a6a 100644 (file)
@@ -44,12 +44,17 @@ define Build/buffalo-dhp-image
        mv $@.new $@
 endef
 
+define Build/eva-image
+       $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
+       mv $@.new $@
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new \
                -k $@ \
                -b $(NETGEAR_BOARD_ID) \
-               -r $(NETGEAR_REGION)
+               $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
        mv $@.new $@
 endef