map: fix psidlen becoming negative (FS#1430)
[openwrt/openwrt.git] / include / image-commands.mk
index 9ec3a84884ba4b6266ee04e96f310ebd9a4bcce8..0f9ac0836cedb5b6d5ac9b327fba1df65ebc72ae 100644 (file)
@@ -118,6 +118,7 @@ define Build/fit
                -D $(DEVICE_NAME) -o $@.its -k $@ \
                $(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
                -A $(LINUX_KARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
        @mv $@.new $@