ath79: add support for Buffalo BHR-4GRV2
[openwrt/openwrt.git] / include / image-commands.mk
index f7e6ba6aa6e730992fef12a0476b36a912626072..143a042fa26ac28ed0f86b712724bb695caf3242 100644 (file)
@@ -62,6 +62,14 @@ define Build/make-ras
        @mv $@.new $@
 endef
 
+define Build/mkbuffaloimg
+       $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
+               -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
+               -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
+               -i $@ -o $@.new
+       mv $@.new $@
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new \