image: allow devices to override the -E 5 ubinize option
[openwrt/openwrt.git] / include / image-commands.mk
index e8549d46f6bc4229a0fec249360a916ead291d5a..17ab46d859e38954350afb031eaab317e513b56b 100644 (file)
@@ -105,8 +105,9 @@ define Build/append-ubi
                $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
                $(word 2,$^) \
                $@.tmp \
                $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
                $(word 2,$^) \
                $@.tmp \
-               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
-               $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
+               -p $(BLOCKSIZE) -m $(PAGESIZE) \
+               $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+               $(UBINIZE_OPTS)
        cat $@.tmp >> $@
        rm $@.tmp
 endef
        cat $@.tmp >> $@
        rm $@.tmp
 endef