build: add UIMAGE_MAGIC to device variables
[openwrt/openwrt.git] / include / image-commands.mk
index de4c86c24a2effde5be0c0593fb39800cf537576..979eafb15734a305320241f796ed735c8e4fe78b 100644 (file)
@@ -402,6 +402,7 @@ define Build/uImage
                -a $(KERNEL_LOADADDR) \
                -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
+               $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC)) \
                $(wordlist 2,$(words $(1)),$(1)) \
                -d $@ $@.new
        mv $@.new $@